PHP 5.4.x < 5.4.1 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 6994

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

PHP versions 5.4.x earlier than 5.4.1 are affected by the following vulnerabilities :

- The '$_FILES' variable can be corrupted because the names of uploaded files are not properly validated. (CVE-2012-1172)

- The 'open_basedir' directive is not properly handled by the functions 'readline_write_history' and 'readline_read_history'.

- It's possible to bypass an HTTP response-splitting protection because the 'sapi_header_op()' function in main/SAPI.c does not properly determine a pointer during checks for encoded carriage return characters. (Bug #60227 / CVE-2012-4388)

Solution

Upgrade to PHP version 5.4.1 or later.

See Also

http://www.nessus.org/u?e81d4026

https://bugs.php.net/bug.php?id=54374

https://bugs.php.net/bug.php?id=60227

http://www.php.net/archive/2012.php#id2012-04-26-1

http://www.php.net/ChangeLog-5.php#5.4.1

Plugin Details

Severity: Medium

ID: 6994

File Name: 6994.prm

Family: Web Servers

Published: 2013/08/20

Modified: 2016/11/23

Dependencies: 8682

Nessus ID: 58967

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2012/04/26

Vulnerability Publication Date: 2012/04/26

Reference Information

CVE: CVE-2012-1172, CVE-2012-4388

BID: 53403, 55527