PHP 5.4.x < 5.4.1 Multiple Vulnerabilities

Medium Nessus Plugin ID 58967


The remote web server uses a version of PHP that is affected by multiple vulnerabilities.


According to its banner, the version of PHP installed on the remote host is 5.4.x earlier than 5.4.1, and, therefore, potentially affected by multiple vulnerabilities :

- The '$_FILES' variable can be corrupted because the names of uploaded files are not properly validated.

- The 'open_basedir' directive is not properly handled by the functions 'readline_write_history' and 'readline_read_history'.

- It's possible to bypass an HTTP response-splitting protection because the 'sapi_header_op()' function in main/SAPI.c does not properly determine a pointer during checks for encoded carriage return characters. (Bug #60227 / CVE-2012-4388)


Upgrade to PHP version 5.4.1 or later.

See Also

Plugin Details

Severity: Medium

ID: 58967

File Name: php_5_4_1.nasl

Version: 1.10

Type: remote

Family: CGI abuses

Published: 2012/05/02

Updated: 2018/07/24

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2012/04/26

Vulnerability Publication Date: 2012/04/26

Reference Information

CVE: CVE-2012-1172, CVE-2012-4388

BID: 53403, 55527