ModSecurity < 2.7.3 XML External Entity (XXE) Data Parsing Arbitrary File Disclosure

High Nessus Network Monitor Plugin ID 6991

Synopsis

The remote web application firewall may be affected by a denial of service vulnerability

Description

According to its banner, the version of ModSecurity installed on the remote host is earlier than 2.7.3. It is, therefore, potentially affected by a file disclosure vulnerability. An improperly configured XML parser could allow untrusted XML entities from external sources to be accepted, thus leading to possible arbitrary file disclosure.

Solution

Upgrade to ModSecurity version 2.7.3 or later.

See Also

http://seclists.org/oss-sec/2013/q2/5

https://github.com/SpiderLabs/ModSecurity/blob/master/CHANGES

http://www.nessus.org/u?13229997

Plugin Details

Severity: High

ID: 6991

Family: Web Servers

Published: 2013/08/16

Modified: 2016/01/15

Dependencies: 1442

Nessus ID: 67127

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:modsecurity:modsecurity

Patch Publication Date: 2013/03/28

Vulnerability Publication Date: 2013/03/22

Reference Information

CVE: CVE-2013-1915

BID: 58810