ModSecurity < 2.7.3 XML External Entity (XXE) Data Parsing Arbitrary File Disclosure

High Nessus Plugin ID 67127


The remote web application firewall may be affected by a file disclosure vulnerability.


According to its banner, the version of ModSecurity installed on the remote host is earlier than 2.7.3. It is, therefore, potentially affected by a file disclosure vulnerability. An improperly configured XML parser could allow untrusted XML entities from external sources to be accepted, thus leading to possible arbitrary file disclosure.

It could also be possible for internal network servers to receive unauthorized requests. Denial of service conditions are also possible.

Note that Nessus has not tested for this issue but has instead relied only on the version in the server's banner.


Upgrade to ModSecurity version 2.7.3 or later.

See Also

Plugin Details

Severity: High

ID: 67127

File Name: modsecurity_2_7_3.nasl

Version: $Revision: 1.6 $

Type: remote

Family: Firewalls

Published: 2013/07/02

Modified: 2014/09/12

Dependencies: 67123

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:modsecurity:modsecurity

Required KB Items: www/ModSecurity, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/03/28

Vulnerability Publication Date: 2013/03/22

Reference Information

CVE: CVE-2013-1915

BID: 58810

OSVDB: 91948