ModSecurity < 2.7.0 Multipart Request Parsing Filter Bypass

Medium Nessus Network Monitor Plugin ID 6990


The remote web application firewall may be affected by a denial of service vulnerability


According to its banner, the version of ModSecurity installed on the remote host is earlier than 2.7.0. It is, therefore, potentially affected by a security bypass vulnerability. An error exists related to HTTP POST requests and 'Content-Disposition' headers containing extra lines that could allow a remote attacker to bypass certain filters and carry out attacks.


Upgrade to ModSecurity version 2.7.0 or later.

See Also

Plugin Details

Severity: Medium

ID: 6990

Family: Web Servers

Published: 2013/08/16

Modified: 2018/09/16

Dependencies: 1442

Nessus ID: 67126

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 5.6

Temporal Score: 5.2


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:modsecurity:modsecurity

Patch Publication Date: 2013/10/15

Vulnerability Publication Date: 2012/10/15

Reference Information

CVE: CVE-2012-4528

BID: 56096