ModSecurity < 2.7.0 Multipart Request Parsing Filter Bypass

Medium Nessus Plugin ID 67126


The remote web application firewall may be affected by a security bypass vulnerability.


According to its banner, the version of ModSecurity installed on the remote host is earlier than 2.7.0. It is, therefore, potentially affected by a security bypass vulnerability. An error exists related to HTTP POST requests and 'Content-Disposition' headers containing extra lines that could allow a remote attacker to bypass certain filters and carry out attacks.

Note that Nessus has not tested for this issue but has instead relied only on the version in the server's banner.


Upgrade to ModSecurity version 2.7.0 or later.

See Also

Plugin Details

Severity: Medium

ID: 67126

File Name: modsecurity_2_7_0.nasl

Version: $Revision: 1.6 $

Type: remote

Family: Firewalls

Published: 2013/07/02

Modified: 2016/11/18

Dependencies: 67123

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:modsecurity:modsecurity

Required KB Items: www/ModSecurity, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/10/15

Vulnerability Publication Date: 2012/10/15

Reference Information

CVE: CVE-2012-4528

BID: 56096

OSVDB: 86408