Apache Subversion 1.7.x < 1.7.11 / 1.8.x < 1.8.1 DoS

Medium Nessus Network Monitor Plugin ID 6963

Synopsis

The remote host is running a version of Apache Subversion that is affected by a denial of service (DoS) vulnerability.

Description

Versions of Apache Subversion 1.7.x prior to 1.7.11, or 1.8.x prior to 1.8.1 are affected by a denial of service vulnerability, specifically within the 'mod_dav_svn' module, which improperly handles certain HTTP requests in a way that can be leveraged by an attacker to execute a denial of service against the system.

Solution

Upgrade to Apache Subversion 1.8.1 or later. If 1.8.x cannot be obtained, 1.7.11 is also patched for these vulnerabilities.

See Also

http://tools.cisco.com/security/center/viewAlert.x?alertId=30213

http://subversion.apache.org/security/CVE-2013-4131-advisory.txt

Plugin Details

Severity: Medium

ID: 6963

File Name: 6963.prm

Family: Web Servers

Published: 2013/08/02

Modified: 2016/03/18

Dependencies: 8971

Nessus ID: 71566

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4

Temporal Score: 3.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 4.3

Temporal Score: 4.1

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:subversion

Patch Publication Date: 2013/07/25

Vulnerability Publication Date: 2013/07/25

Reference Information

CVE: CVE-2013-4131

BID: 61454

OSVDB: 95885