Apache 2.4.1 to 2.4.4 Multiple Vulnerabilities

high Nessus Network Monitor Plugin ID 6942

Synopsis

The remote web server is affected by multiple vulnerabilities

Description

The remote host is running an Apache HTTP server. Versions 2.4.1 to 2.4.4 inclusive are vulnerable to the following vulnerabilities :

- A denial of service vulnerability exists relating to the 'mod_dav' module as it relates to MERGE requests. (CVE-2013-1896)

- An error exists related to the 'mod_session_dbd' module, flags and session-saving having an unspecified impact.(CVE-2013-2249).

Solution

Either ensure that the affected modules are not in use or upgrade to Apache version 2.4.6 or later.

See Also

http://httpd.apache.org/security/vulnerabilities_24.html

https://archive.apache.org/dist/httpd/CHANGES_2.4.6

Plugin Details

Severity: High

ID: 6942

Family: Web Servers

Published: 7/23/2013

Updated: 3/6/2019

Dependencies: 3057

Nessus ID: 69014

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:2.4:*:*:*:*:*:*:*

Patch Publication Date: 7/22/2013

Vulnerability Publication Date: 5/23/2013

Reference Information

CVE: CVE-2013-1896, CVE-2013-2249

BID: 61129, 61379

IAVA: 2015-A-0149