Samba 3.6.x < 3.6.6 Remote Security Bypass

Medium Nessus Network Monitor Plugin ID 6930

Synopsis

The remote Samba server is affected by a remote security bypass vulnerability

Description

According to its banner, the version of Samba 3.6.x running on the remote host is earlier than 3.6.x. It is, therefore, affected by a remote security bypass vulnerability because it fails to properly enforce CIFS share attributes.

This may allow a remote, authenticated attacker to write to read-only shares, impact integrity related to oplock, locking, coherency, or leases or leases attributes

Solution

Either install the patch referenced in the project's advisory or upgrade to 3.6.6 or later.

See Also

https://www.samba.org/samba/security/CVE-2013-0454

http://www.samba.org/samba/history/samba-3.6.6.html

Plugin Details

Severity: Medium

ID: 6930

File Name: 6930.prm

Family: Samba

Published: 2012/07/17

Modified: 2016/02/05

Dependencies: 8740

Nessus ID: 67118

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 4.2

Temporal Score: 3.6

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2012/06/25

Vulnerability Publication Date: 2012/06/25

Reference Information

CVE: CVE-2013-0454

BID: 58655