OpenSSL < 0.9.8y / 1.0.1d / 1.0.0k Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 6868

Synopsis

The remote web server is running an OpenSSL instance that may be affected by multiple vulnerabilities.

Description

Versions of OpenSSL prior to 0.9.8y are reportedly affected by the following vulnerabilities :

- An error exists related to the handling of OCSP response verification that could allow denial of service attacks. (CVE-2013-0166)

- An error exists related to the SSL/TLS/DTLS protocols, CBC mode encryption and response time. An attacker could obtain plaintext contents of encrypted traffic via timing attacks. (CVE-2013-0169)

Solution

Upgrade to OpenSSL version 0.9.8y / 1.0.1d / 1.0.0k or later.

See Also

http://www.openssl.org/news/secadv_20130204.txt

Plugin Details

Severity: Medium

ID: 6868

File Name: 6868.prm

Family: Web Servers

Published: 2013/06/11

Modified: 2016/02/05

Dependencies: 5563

Nessus ID: 64532

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 3.6

Temporal Score: 3.3

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Patch Publication Date: 2013/06/03

Vulnerability Publication Date: 2013/06/03

Reference Information

CVE: CVE-2013-0169, CVE-2013-0166, CVE-2012-2686

BID: 60268