Squid < 3.1.23 / 3.2.x < 3.2.6 / 3.3.x < 3.3.0.3 cachemgr.cgi DoS

Medium Nessus Network Monitor Plugin ID 6850

Synopsis

The remote proxy server is vulnerable to a Denial of Service (DoS) attack.

Description

Squid versions prior to 3.1.23, 3.2.x prior to 3.2.6, and 3.3.x prior to 3.3.0.3 are potentially affected by a denial of service vulnerability. The included 'cachemgr.cgi' tool reportedly lacks input validation, which could be abused by any client able to access that tool to perform a denial of service attack on the service host.

Note this fix is a result of an incomplete fix for CVE-2012-5643.

Solution

Upgrade to Squid version 3.1.23 / 3.2.6 / 3.3.0.3 or later, or apply the vendor-supplied patch.

See Also

http://www.squid-cache.org/Advisories/SQUID-2012_1.txt

Plugin Details

Severity: Medium

ID: 6850

Family: Web Servers

Published: 2013/02/08

Modified: 2016/11/23

Dependencies: 3389

Nessus ID: 63318, 63336, 64376, 64501, 64513, 64514, 64745, 66141

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 3.6

Temporal Score: 3.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Patch Publication Date: 2013/01/01

Vulnerability Publication Date: 2012/12/17

Reference Information

CVE: CVE-2012-5643, CVE-2013-0189

BID: 56957, 57646