Squid 2.x / 3.x < 3.1.22 / 3.2.4 / 184.108.40.206 cachemgr.cgi DoS
Medium Nessus Plugin ID 63318
SynopsisThe remote proxy server is affected by a denial of service vulnerability.
DescriptionAccording to its banner, the version of Squid running on the remote host is 2.x or 3.x prior to 3.1.22 / 3.2.4 / 220.127.116.11. The included 'cachemgr.cgi' tool reportedly lacks input validation, which could be abused by any client able to access that tool to perform a denial of service attack on the service host. Note that Nessus did not actually test for this issue but has instead relied on the version in the server's banner.
SolutionEither upgrade to Squid version 3.1.22 / 3.2.4 / 18.104.22.168 or later, or apply the vendor-supplied patch.
Alternatively, restrict access to this CGI or limit CGI memory consumption via the host web server's configuration options.