Squid 2.x / 3.x < 3.1.22 / 3.2.4 / cachemgr.cgi DoS

medium Nessus Plugin ID 63318
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote proxy server is affected by a denial of service vulnerability.


According to its banner, the version of Squid running on the remote host is 2.x or 3.x prior to 3.1.22 / 3.2.4 / The included 'cachemgr.cgi' tool reportedly lacks input validation, which could be abused by any client able to access that tool to perform a denial of service attack on the service host. Note that Nessus did not actually test for this issue but has instead relied on the version in the server's banner.


Either upgrade to Squid version 3.1.22 / 3.2.4 / or later, or apply the vendor-supplied patch.

Alternatively, restrict access to this CGI or limit CGI memory consumption via the host web server's configuration options.

See Also


Plugin Details

Severity: Medium

ID: 63318

File Name: squid_3_2_3.nasl

Version: 1.12

Type: remote

Family: Firewalls

Published: 12/20/2012

Updated: 9/17/2018

Dependencies: squid_version.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2012-5643


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: www/squid, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 11/15/2012

Vulnerability Publication Date: 12/17/2012

Reference Information

CVE: CVE-2012-5643

BID: 56957