PostgreSQL < 8.4.11 / 9.0.7 / 9.1.3 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 6817

Synopsis

The remote database server is affected by multiple vulnerabilities

Description

Versions of PostgreSQL earlier than 8.4.11 / 9.0.7 / 9.1.3 are potentially affected by multiple vulnerabilities. It therefore is affected by the following vulnerabilities :

- Permissions on a function called by a trigger are not properly checked. (CVE-2012-0866)

- SSL certificate name checks are truncated to 32 characters, allowing connection spoofing under some circumstances when using third party certificate authorities. (CVE-2012-0867)

- Line breaks in object names can be exploited to execute arbitrary SQL commands when reloading a pg_dump file. (CVE-2012-0868)

Solution

Upgrade to PostgreSQL 8.4.12 / 9.0.8 / 9.1.4 or later.

See Also

http://www.postgresql.org/about/news/1377

http://www.postgresql.org/docs/8.4/static/release-8-4-11.html

http://www.postgresql.org/docs/9.0/static/release-9-0-7.html

http://www.postgresql.org/docs/9.1/static/release-9-1-3.html

Plugin Details

Severity: Medium

ID: 6817

Family: Database

Published: 2013/05/14

Modified: 2016/01/19

Dependencies: 8704, 8705

Nessus ID: 63352

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2012/02/27

Vulnerability Publication Date: 2012/02/27

Reference Information

CVE: CVE-2012-0866, CVE-2012-0867, CVE-2012-0868

BID: 52188