Flash Player <= 10.3.183.16 / 11.1.102.63 Multiple Memory Corruption Vulnerabilities (APSB12-07)

High Nessus Network Monitor Plugin ID 6802

Synopsis

The remote host contains a browser plug-in that is affected by multiple memory corruption vulnerabilities

Description

The remote host has Adobe Flash Player installed.

Versions of Flash Player 10.x equal to or earlier than 10.3.183.16 or 11.x equal to or ealier than 11.1.102.63 are potentially affected by several critical memory corruption vulnerabilities :

- Memory corruption vulnerabilities related to URL security domain checking. (CVE-2012-0772)

- A flaw in the NetStream Class that could lead to remote code execution. (CVE-2012-0773)

- Two Flash Player memory corruption vulnerabilities related to the Google Chrome interface. (CVE-2012-0724, CVE-2012-0725)

By tricking a victim into visiting a specially crafted page, an attacker may be able to utilize these vulnerabilities to execute arbitrary code subject to the users' privileges

Solution

Upgrade to Flash Player 10.3.183.18 / 11.2.202.228 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb12-07.html

http://www.securityfocus.com/archive/1/522413/30/0/threaded

http://www.zerodayinitiative.com/advisories/ZDI-12-057

Plugin Details

Severity: High

ID: 6802

Family: Web Clients

Published: 2013/05/08

Updated: 2019/03/06

Dependencies: 1735, 8314

Nessus ID: 58538

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 8.1

Temporal Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2012/03/28

Vulnerability Publication Date: 2012/03/28

Reference Information

CVE: CVE-2012-0772, CVE-2012-0773, CVE-2012-0724, CVE-2012-0725

BID: 52748, 52914, 52916