Oracle MySQL Server 5.5.x < 5.5.30 yaSSL Buffer Overflow

High Nessus Network Monitor Plugin ID 6766

Synopsis

The remote database server is affected by a buffer overflow vulnerability

Description

The version of MySQL 5.5 installed on the remote host is earlier than 5.5.30. Therefore, affected by a buffer overflow related to 'yaSSL'. This error could possibly allow arbitrary code execution.

Solution

Upgrade to MySQL version 5.5.30 or later.

See Also

http://dev.mysql.com/doc/refman/5.5/en/news-5-5-30.html

http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-30.html

https://blogs.oracle.com/sunsecurity/entry/cve_2012_0553_buffer_overflow

http://www.nessus.org/u?ef866628

Plugin Details

Severity: High

ID: 6766

File Name: 6766.prm

Family: Database

Published: 2013/04/22

Modified: 2016/01/19

Dependencies: 8914

Nessus ID: 65734

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Patch Publication Date: 2013/02/05

Vulnerability Publication Date: 2013/03/19

Reference Information

CVE: CVE-2013-1492

BID: 58595

OSVDB: 91534