MySQL 5.5 < 5.5.30 yaSSL Buffer Overflow

high Nessus Plugin ID 65734


The remote database server is affected by a buffer overflow vulnerability.


The version of MySQL 5.5 installed on the remote host is earlier than 5.5.30 and is, therefore, affected a buffer overflow related to 'yaSSL'.
This error could possibly allow arbitrary code execution.


Upgrade to MySQL version 5.5.30 or later.

See Also

Plugin Details

Severity: High

ID: 65734

File Name: mysql_5_5_30.nasl

Version: 1.7

Type: remote

Family: Databases

Published: 3/29/2013

Updated: 11/27/2019

Configuration: Enable paranoid mode

Supported Sensors: Frictionless Assessment Agent, Nessus

Risk Information


Risk Factor: Medium

Score: 5.8


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2013-1492

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2/5/2013

Vulnerability Publication Date: 3/19/2013

Reference Information

CVE: CVE-2013-1492

BID: 58595