MySQL 5.5 < 5.5.30 yaSSL Buffer Overflow

high Nessus Plugin ID 65734
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by a buffer overflow vulnerability.

Description

The version of MySQL 5.5 installed on the remote host is earlier than 5.5.30 and is, therefore, affected a buffer overflow related to 'yaSSL'.
This error could possibly allow arbitrary code execution.

Solution

Upgrade to MySQL version 5.5.30 or later.

See Also

https://www.zerodayinitiative.com/advisories/ZDI-13-251/

http://dev.mysql.com/doc/refman/5.5/en/news-5-5-30.html

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-30.html

https://blogs.oracle.com/sunsecurity/cve-2012-0553-buffer-overflow-vulnerability-in-yassl

http://www.nessus.org/u?c79e27db

Plugin Details

Severity: High

ID: 65734

File Name: mysql_5_5_30.nasl

Version: 1.7

Type: remote

Family: Databases

Published: 3/29/2013

Updated: 11/27/2019

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2013-1492

VPR

Risk Factor: Medium

Score: 5.8

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2/5/2013

Vulnerability Publication Date: 3/19/2013

Reference Information

CVE: CVE-2013-1492

BID: 58595