Squid 3.x < 3.2.9 / 3.3.x < 3.3.3 strHdrAcptLangGetItem DoS

Medium Nessus Network Monitor Plugin ID 6748

Synopsis

The remote proxy server is vulnerable to a denial-of-service attack.

Description

Squid version prior to 3.2.9 or 3.3.3 are potentially affected by a denial of service vulnerability. An error exists in the function 'strHdrAcptLangGetItem' in the field 'errorpage.cc' that would allow certain 'Accept-Language' HTTP headers to cause a denial of service condition.

Solution

Upgrade to Squid 3.2.9 / 3.3.3 or later, or apply the vedor-supplied patch

See Also

http://www.squid-cache.org/Advisories/SQUID-2013_1.txt

http://seclists.org/bugtraq/2013/Mar/68

http://www.nessus.org/u?bd6b7229

Plugin Details

Severity: Medium

ID: 6748

File Name: 6748.prm

Family: Web Servers

Published: 2013/03/26

Modified: 2016/11/23

Dependencies: 3389

Nessus ID: 65601

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 3.6

Temporal Score: 3.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Patch Publication Date: 2013/03/05

Vulnerability Publication Date: 2013/03/05

Reference Information

CVE: CVE-2013-1839

BID: 58316