Squid 3.x < 3.2.9 / 3.3.3 strHdrAcptLangGetItem Malformed Accept-Language Denial of Service

Medium Nessus Plugin ID 65601


The remote proxy server is affected by a denial of service vulnerability.


According to its banner, the version of Squid running on the remote host is 3.2.x prior to 3.2.9 or 3.3.x prior to 3.3.3 and is, therefore, affected by a denial of service vulnerability. An error exists in the function 'strHdrAcptLangGetItem' in the file 'errorpage.cc' that could allow certain 'Accept-Language' HTTP headers to cause a denial of service condition.

Note that Nessus has relied only on the version in the proxy server's banner, which is not updated by the patch the project has released to address the issue. If this patch has been applied properly and the service has been restarted, consider this to be a false positive.


Either upgrade to Squid version 3.2.9 / 3.3.3 or later, or apply the vendor-supplied patch.

See Also




Plugin Details

Severity: Medium

ID: 65601

File Name: squid_3_2_9.nasl

Version: $Revision: 1.4 $

Type: remote

Family: Firewalls

Published: 2013/03/18

Modified: 2014/05/24

Dependencies: 49692

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: www/squid, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/03/05

Vulnerability Publication Date: 2013/03/05

Reference Information

CVE: CVE-2013-1839

BID: 58316

OSVDB: 90910