PostgreSQL < 8.4.17 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 6746

Synopsis

The remote database server is vulnerable to multiple vulnerabilities

Description

Versions of PostgreSQL earlier than 9.1.9 or 9.2.4 and are potentially affected by the following vulnerabilities :

- An information disclosure due to an error in the 'contrib\pgcrypto' functions. (CVE-2013-1900)

- An insecure temporary file-creation, specifically occurs when a file with a predictable filename in the '/tmp' directory is created. (CVE-2013-1902)

- A password disclosure vulnerability occurs due to the application passing the database superuser passwords to a script, specifically exists in the graphical installers package. (CVE-2013-1093)

Solution

Upgrade to PostgreSQL 8.4.17 or later.

See Also

http://www.postgresql.org/about/news/1456

http://www.postgresql.org/docs/9.2/static/release-8-4-17.html

Plugin Details

Severity: Medium

ID: 6746

Family: Database

Published: 2013/04/05

Modified: 2016/01/21

Dependencies: 8704

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2013/04/04

Vulnerability Publication Date: 2013/04/04

Reference Information

CVE: CVE-2013-1900, CVE-2013-1902, CVE-2013-1903

BID: 58877, 58879, 58882