PostgreSQL < 8.3.23 / 8.4.16 / 9.0.12 / 9.1.8 / 9.2.3 Denial of Service

Medium Nessus Network Monitor Plugin ID 6743

Synopsis

The remote database server is vulnerable to a denial of service vulnerability.

Description

Versions of PostgreSQL earlier than 8.3.23, 8.4.16, 9.0.12, 9.1.8, 9.2.3 and are potentially affected by a denial of service vulnerability due to a flaw in the enum_recv() functin of 'backend/utils/adt/enum.c'. By exploiting this flaw, a remote attacker could crash the affected application

Solution

Upgrade to PostgreSQL 8.3.23 / 8.4.16 / 9.0.12 / 9.1.8 / 9.2.3 or later.

See Also

http://www.postgresql.org/about/news/1446

http://www.postgresql.org/docs/8.3/static/release-8-3-23.html

http://www.postgresql.org/docs/8.4/static/release-8-4-16.html

http://www.postgresql.org/docs/9.0/static/release-9-0-12.html

http://www.postgresql.org/docs/9.1/static/release-9-1-8.html

http://www.postgresql.org/docs/9.2/static/release-9-2-3.html

Plugin Details

Severity: Medium

ID: 6743

File Name: 6743.prm

Family: Database

Published: 2013/04/05

Modified: 2016/01/21

Dependencies: 8704, 8705

Nessus ID: 64669

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2013/02/07

Vulnerability Publication Date: 2013/02/07

Reference Information

CVE: CVE-2013-0255

BID: 57844