PostgreSQL 8.3 < 8.3.23 / 8.4 < 8.4.16 / 9.0 < 9.0.12 / 9.1 < 9.1.8 / 9.2 < 9.2.3 Denial of Service

Medium Nessus Plugin ID 64669

Synopsis

The remote database server is affected by a denial of service vulnerability.

Description

The version of PostgreSQL installed on the remote host is 8.3.x prior to 8.3.23, 8.4.x prior to 8.4.16, 9.0.x prior to 9.0.12, 9.1.x prior to 9.1.8 or 9.2 prior to 9.2.3. It is, therefore, potentially affected by a denial of service vulnerability due to a flaw in the enum_recv() function of 'backend/utils/adt/enum.c'. By exploiting this flaw, a remote attacker could crash the affected application.

Solution

Upgrade to PostgreSQL 8.3.23 / 8.4.16 / 9.0.12 / 9.1.8 / 9.2.3 or later.

See Also

https://www.postgresql.org/about/news/1446/

https://www.postgresql.org/docs/8.3/release-8-3-23.html

https://www.postgresql.org/docs/8.4/release-8-4-16.html

https://www.postgresql.org/docs/9.0/release-9-0-12.html

http://www.postgresql.org/docs/9.1/static/release-9-1-8.html

http://www.postgresql.org/docs/9.2/static/release-9-2-3.html

Plugin Details

Severity: Medium

ID: 64669

File Name: postgresql_20130207.nasl

Version: 1.12

Type: remote

Family: Databases

Published: 2013/02/18

Updated: 2019/02/26

Dependencies: 63346

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2013-0255

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/02/07

Vulnerability Publication Date: 2013/02/07

Reference Information

CVE: CVE-2013-0255

BID: 57844