Apache 2.2 < 2.2.24 Multiple Cross-Site Scripting Vulnerabilites

low Nessus Network Monitor Plugin ID 6701
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is affected by multiple vulnerabilities

Description

The remote host is running a Apache HTTP server.

Versions earlier than 2.4.4 are vulnerable to the following vulnerabilities :

- Errors exist related to the modules mod_info, mod_status, mod_imagemap, mod_ldap, and mod_proxy_ftp and unescaped hostnames and URIs that could allow cross-site scripting attacks. (CVE-2012-3499)

- An error exists related to the mod_proxy_balancer module's manager interface that could allow cross-site scripting attacks. (CVE-2012-4558)

Solution

Either ensure that the affected modules are not in use or upgrade to Apache version 2.2.24 or later

See Also

http://httpd.apache.org/security/vulnerabilities_22.html

https://archive.apache.org/dist/httpd/CHANGES_2.2.24

Plugin Details

Severity: Low

ID: 6701

Family: Web Servers

Published: 2/27/2013

Updated: 3/6/2019

Dependencies: 3057

Nessus ID: 64912

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Low

Base Score: 3.7

Temporal Score: 3.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:2.2:*:*:*:*:*:*:*

Patch Publication Date: 2/25/2013

Vulnerability Publication Date: 2/18/2013

Reference Information

CVE: CVE-2012-3499, CVE-2012-4558

BID: 58165

IAVA: 2015-A-0149