Apache 2.2.x < 2.2.24 Multiple XSS Vulnerabilities

Medium Nessus Plugin ID 64912


The remote web server is affected by multiple cross-site scripting vulnerabilities.


According to its banner, the version of Apache 2.2.x running on the remote host is prior to 2.2.24. It is, therefore, potentially affected by the following cross-site scripting vulnerabilities :

- Errors exist related to the modules mod_info, mod_status, mod_imagemap, mod_ldap, and mod_proxy_ftp and unescaped hostnames and URIs that could allow cross- site scripting attacks. (CVE-2012-3499)

- An error exists related to the mod_proxy_balancer module's manager interface that could allow cross-site scripting attacks. (CVE-2012-4558)

Note that Nessus did not actually test for these issues, but instead has relied on the version in the server's banner.


Upgrade to Apache version 2.2.24 or later. Alternatively, ensure that the affected modules are not in use.

See Also



Plugin Details

Severity: Medium

ID: 64912

File Name: apache_2_2_24.nasl

Version: $Revision: 1.17 $

Type: remote

Family: Web Servers

Published: 2013/02/27

Modified: 2018/01/22

Dependencies: 48204

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/02/26

Vulnerability Publication Date: 2013/02/18

Reference Information

CVE: CVE-2012-3499, CVE-2012-4558

BID: 58165

OSVDB: 90556, 90557

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990