Apache 2.4.1 to 2.4.3 Multiple Cross-Site Scripting Vulnerabilites

Medium Nessus Network Monitor Plugin ID 6700


The remote web server is affected by multiple vulnerabilities


The remote host is running a Apache HTTP server.

Versions 2.4.1 to 2.4.3 inclusive are vulnerable to the following vulnerabilities :

- Errors exist related to the modules mod_info, mod_status, mod_imagemap, mod_ldap, and mod_proxy_ftp and unescaped hostnames and URIs that could allow cross-site scripting attacks. (CVE-2012-3499)

- An error exists related to the mod_proxy_balancer module's manager interface that could allow cross-site scripting attacks. (CVE-2012-4558)


Either ensure that the affected modules are not in use or upgrade to Apache version 2.4.4 or later

See Also



Plugin Details

Severity: Medium

ID: 6700

File Name: 6700.prm

Family: Web Servers

Published: 2013/02/27

Modified: 2018/02/20

Dependencies: 3057

Nessus ID: 64893

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 4.6


Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server:2.4

Patch Publication Date: 2013/02/25

Vulnerability Publication Date: 2013/02/18

Reference Information

CVE: CVE-2012-3499, CVE-2012-4558

BID: 58165

OSVDB: 90556, 90557

IAVA: 2015-A-0149