Apache 2.4.x < 2.4.4 Multiple XSS Vulnerabilities

Medium Nessus Plugin ID 64893

Synopsis

The remote web server may be affected by multiple cross-site scripting vulnerabilities.

Description

According to its banner, the version of Apache 2.4.x running on the remote host is prior to 2.4.4. It is, therefore, affected by the following cross-site scripting vulnerabilities :

- Errors exist related to the modules mod_info, mod_status, mod_imagemap, mod_ldap, and mod_proxy_ftp and unescaped hostnames and URIs that could allow cross- site scripting attacks. (CVE-2012-3499)

- An error exists related to the mod_proxy_balancer module's manager interface that could allow cross-site scripting attacks. (CVE-2012-4558)

Note that Nessus did not actually test for these issues, but instead has relied on the version in the server's banner.

Solution

Upgrade to Apache version 2.4.4 or later. Alternatively, ensure that the affected modules are not in use.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.4.4

http://httpd.apache.org/security/vulnerabilities_24.html

Plugin Details

Severity: Medium

ID: 64893

File Name: apache_2_4_4.nasl

Version: 1.17

Type: remote

Family: Web Servers

Published: 2013/02/26

Updated: 2018/06/29

Dependencies: 48204

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.9

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/02/25

Vulnerability Publication Date: 2013/02/18

Reference Information

CVE: CVE-2012-3499, CVE-2012-4558

BID: 58165

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990