Flash Player <= 10.3.183.43 / 11.5.502.110 Multiple Vulnerabilities (APSB12-27)

High Nessus Network Monitor Plugin ID 6647

Synopsis

The remote host contains a browser plug-in that is affected by multiple vulnerabilities.

Description

The remote host has Adobe Flash Player installed.

Versions of Flash Player 11.x equal to or earlier than 11.5.502.110, or 10.x equal to or earlier than 10.3.183.43 are affected by multiple vulnerabilities:

- An unspecified error exists that can allow a buffer overflow and arbitrary code execution. (CVE-2012-5676)

- An unspecified error exists that can allow an integer overflow and arbitrary code execution. (CVE-2012-5677)

- An unspecified error exists that can lead to memory corruption and arbitrary code execution. (CVE-2012-5678)

Solution

Upgrade to Flash Player 10.3.183.48 / 11.5.502.135 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb12-27.html

Plugin Details

Severity: High

ID: 6647

File Name: 6647.prm

Family: Web Clients

Published: 2011/12/17

Modified: 2016/01/19

Dependencies: 1735, 8314

Nessus ID: 63242

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2012/12/11

Vulnerability Publication Date: 2012/12/11

Reference Information

CVE: CVE-2012-5676, CVE-2012-5677, CVE-2012-5678

BID: 56892, 56896, 56898