Flash Player <= / 11.5.502.110 Multiple Vulnerabilities (APSB12-27)

High Nessus Plugin ID 63242


The remote Windows host has a browser plugin that is affected by multiple vulnerabilities.


According to its version, the instance of Flash Player installed on the remote Windows host is 11.x equal to or earlier than 11.5.502.110, or 10.x equal to or earlier than It is, therefore, potentially affected by multiple vulnerabilities :

- An unspecified error exists that can allow a buffer overflow and arbitrary code execution. (CVE-2012-5676)

- An unspecified error exists that can allow an integer overflow and arbitrary code execution. (CVE-2012-5677)

- An unspecified error exists that can lead to memory corruption and arbitrary code execution. (CVE-2012-5678)


Upgrade to Adobe Flash Player version / 11.5.502.135 or later, or Google Chrome PepperFlash or later.

See Also



Plugin Details

Severity: High

ID: 63242

File Name: flash_player_apsb12-27.nasl

Version: $Revision: 1.9 $

Type: local

Agent: windows

Family: Windows

Published: 2012/12/12

Modified: 2015/10/13

Dependencies: 28211

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: SMB/Flash_Player/installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/12/11

Vulnerability Publication Date: 2012/12/11

Reference Information

CVE: CVE-2012-5676, CVE-2012-5677, CVE-2012-5678

BID: 56892, 56896, 56898

OSVDB: 88353, 88354, 88356