PHP 5.3.x < 5.3.15 Multiple Vulnerabilities

Critical Nessus Network Monitor Plugin ID 6556

Synopsis

The remote web server uses a version of PHP that is affected by an multiple vulnerabilities.

Description

PHP versions 5.3.x earlier than 5.3.15 are affected by the following vulnerabilities.

- - An unspecified overflow vulnerability exists in the function '_php_stream_scandir' in the file 'main/streams/streams.c'. (CVE-2012-2688)

- An unspecified error exists that can allow the 'open_basedir' constraint to be bypassed. (CVE-2012-3365)

Solution

Upgrade to PHP version 5.3.15 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.3.15

Plugin Details

Severity: Critical

ID: 6556

Family: Web Servers

Published: 2012/08/28

Updated: 2019/03/06

Dependencies: 8682

Nessus ID: 60085

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2012/07/19

Vulnerability Publication Date: 2012/07/19

Reference Information

CVE: CVE-2012-2688, CVE-2012-3365

BID: 54612, 54638