PHP 5.3.x < 5.3.15 Multiple Vulnerabilities

Critical Nessus Plugin ID 60085

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP installed on the remote host is 5.3.x earlier than 5.3.15, and is, therefore, potentially affected by the following vulnerabilities :

- An unspecified overflow vulnerability exists in the function '_php_stream_scandir' in the file 'main/streams/streams.c'. (CVE-2012-2688)

- An unspecified error exists that can allow the 'open_basedir' constraint to be bypassed.
(CVE-2012-3365)

Solution

Upgrade to PHP version 5.3.15 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.3.15

Plugin Details

Severity: Critical

ID: 60085

File Name: php_5_3_15.nasl

Version: 1.9

Type: remote

Family: CGI abuses

Published: 2012/07/20

Updated: 2018/07/24

Dependencies: 48243

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2012/07/19

Vulnerability Publication Date: 2012/07/19

Reference Information

CVE: CVE-2012-2688, CVE-2012-3365

BID: 54612, 54638