Apache 2.4.1, 2.4.2 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 6550

Synopsis

The remote web server is affected by multiple vulnerabilities

Description

The remote host is running a Apache HTTP server.

Versions 2.4.1 and 2.4.2 are vulnerable to the following vulnerabilities :

- An input validation error exists related to 'mod_negotiation', 'Multiviews' and untrusted uploads that can allow cross-site scripting attacks. (CVE-2012-2687)

- An error exists related to 'mod_proxy_ajp' and 'mod_proxy_http' that can allow connections to remain open. This condition can allow information disclosure when combined with specially crafted requests. (CVE-2012-3502)

Solution

Upgrade to Apache version 2.4.3 or later

See Also

http://httpd.apache.org/security/vulnerabilities_24.html

https://archive.apache.org/dist/httpd/CHANGES_2.4.3

https://issues.apache.org/bugzilla/show_bug.cgi?id=53727

Plugin Details

Severity: Medium

ID: 6550

Family: Web Servers

Published: 8/23/2012

Updated: 3/6/2019

Nessus ID: 61644

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:2.4:*:*:*:*:*:*:*

Patch Publication Date: 8/21/2012

Vulnerability Publication Date: 6/13/2012

Reference Information

CVE: CVE-2012-2687, CVE-2012-3502

BID: 55131

IAVA: 2015-A-0149