Apache 2.4.1, 2.4.2 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 6550


The remote web server is affected by multiple vulnerabilities


The remote host is running a Apache HTTP server.

Versions 2.4.1 and 2.4.2 are vulnerable to the following vulnerabilities :

- An input validation error exists related to 'mod_negotiation', 'Multiviews' and untrusted uploads that can allow cross-site scripting attacks. (CVE-2012-2687)

- An error exists related to 'mod_proxy_ajp' and 'mod_proxy_http' that can allow connections to remain open. This condition can allow information disclosure when combined with specially crafted requests. (CVE-2012-3502)


Upgrade to Apache version 2.4.3 or later

See Also




Plugin Details

Severity: Medium

ID: 6550

Family: Web Servers

Published: 2012/08/23

Updated: 2019/03/06

Dependencies: 3057

Nessus ID: 61644

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server:2.4

Patch Publication Date: 2012/08/21

Vulnerability Publication Date: 2012/06/13

Reference Information

CVE: CVE-2012-2687, CVE-2012-3502

BID: 55131

IAVA: 2015-A-0149