Apache 2.4.x < 2.4.3 Multiple Vulnerabilities

Medium Nessus Plugin ID 61644

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 3.8

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

According to its banner, the version of Apache 2.4.x running on the remote host is prior 2.4.3. It is, therefore, affected by the following vulnerabilities :

- An input validation error exists related to 'mod_negotiation', 'Multiviews' and untrusted uploads that can allow cross-site scripting attacks.
(CVE-2012-2687)

- An error exists related to 'mod_proxy_ajp' and 'mod_proxy_http' that can allow connections to remain open. This condition can allow information disclosure when combined with specially crafted requests.
(CVE-2012-3502)

Note that Nessus did not actually test for these issues, but instead has relied on the version in the server's banner.

Solution

Upgrade to Apache version 2.4.3 or later.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.4.3

http://httpd.apache.org/security/vulnerabilities_24.html

https://bz.apache.org/bugzilla/show_bug.cgi?id=53727

Plugin Details

Severity: Medium

ID: 61644

File Name: apache_2_4_3.nasl

Version: 1.18

Type: remote

Family: Web Servers

Published: 2012/08/23

Updated: 2018/11/15

Dependencies: 48204

Risk Information

Risk Factor: Medium

VPR Score: 3.8

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/08/21

Vulnerability Publication Date: 2012/06/13

Reference Information

CVE: CVE-2012-2687, CVE-2012-3502

BID: 55131

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990