Flash Player < 10.3.183.20 / 11.3.300.257 Multiple Vulnerabilities (APSB12-14)

High Nessus Network Monitor Plugin ID 6545

Synopsis

The remote host contains a browser plugin that is affected by multiple vulnerabilities

Description

Versions of Flash Player earlier than 10.3.189.19 / 11.3.300.256 are potentially affected by multiple vulnerabilities :

- Multiple memory corruption vulnerabilities exist that could lead to code execution. (CVE-2012-2034, CVE-2012-2037)
- A stack overflow vulnerability exists that could lead to code execution. (CVE-2012-2035)
- An integer overflow vulnerability exists that could lead to code execution. (CVE-2012-2036)
- A security bypass vulnerability exists that could lead to information disclosure. (CVE-2012-2038)
- A null dereference vulnerability exists that could lead to code execution. (CVE-2012-2039)
- A binary planting vulnerability exists in the Flash Player installer that could lead to code execution.(CVE-2012-2040)

Solution

Upgrade to Flash Player 10.3.183.20 / 11.3.300.257 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb12-14.html

Plugin Details

Severity: High

ID: 6545

Family: Web Clients

Published: 2011/06/29

Modified: 2016/01/19

Dependencies: 5783

Nessus ID: 59426, 59428

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2012/06/08

Vulnerability Publication Date: 2012/06/08

Reference Information

CVE: CVE-2012-2034, CVE-2012-2035, CVE-2012-2036, CVE-2012-2037, CVE-2012-2038, CVE-2012-2039, CVE-2012-2040

BID: 53887