Flash Player for Mac <= 10.3.183.19 / 11.3.300.256 Multiple Vulnerabilities (APSB12-14)

High Nessus Plugin ID 59428

Synopsis

The remote Mac OS X host has a browser plugin that is affected by
multiple vulnerabilities.

Description

According to its version, the instance of Flash Player installed on
the remote Mac OS X host is 10.x equal to or earlier than 10.3.183.19
or 11.x equal to or earlier than 11.3.300.256. It is, therefore,
potentially affected by multiple vulnerabilities :

- Multiple memory corruption vulnerabilities exist that
could lead to code execution.
(CVE-2012-2034, CVE-2012-2037)

- A stack overflow vulnerability exists that could lead to
code execution. (CVE-2012-2035)

- An integer overflow vulnerability exists that could lead
to code execution. (CVE-2012-2036)

- A security bypass vulnerability exists that could lead
to information disclosure. (CVE-2012-2038)

- A null dereference vulnerability exists that could lead
to code execution. (CVE-2012-2039)

- A binary planting vulnerability exists in the Flash
Player installer that could lead to code execution.
(CVE-2012-2040)

Solution

Upgrade to Adobe Flash Player version 10.3.183.20 / 11.3.300.257 or
later.

See Also

http://www.adobe.com/support/security/bulletins/apsb12-14.html

Plugin Details

Severity: High

ID: 59428

File Name: macosx_flash_player_11_3_300_257.nasl

Version: 1.8

Type: local

Agent: macosx

Published: 2012/06/09

Modified: 2018/07/14

Dependencies: 53914

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/06/08

Vulnerability Publication Date: 2012/06/08

Reference Information

CVE: CVE-2012-2034, CVE-2012-2035, CVE-2012-2036, CVE-2012-2037, CVE-2012-2038, CVE-2012-2039, CVE-2012-2040

BID: 53887