PHP 5.4.x < 5.4.5 _php_stream_scandir Overflow

critical Nessus Network Monitor Plugin ID 6530
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is affected by an overflow vulnerability.

Description

Versions of PHP 5.4.x prior to 5.4.5 are affected by an unspecified overflow vulnerability in the function '_php_stream_scandir' in the file 'main/streams/streams.c'. No further details have been provided by the vendor.

Solution

Upgrade to PHP version 5.4.5 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.4.5

Plugin Details

Severity: Critical

ID: 6530

Family: Web Servers

Published: 8/6/2012

Updated: 3/6/2019

Dependencies: 8682

Nessus ID: 60086

Risk Information

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Patch Publication Date: 7/19/2012

Vulnerability Publication Date: 7/19/2012

Reference Information

CVE: CVE-2012-2688

BID: 54638