PHP 5.4.x < 5.4.5 _php_stream_scandir Overflow

Critical Nessus Plugin ID 60086


The remote web server uses a version of PHP that is affected by an overflow vulnerability.


According to its banner, the version of PHP installed on the remote host is 5.4.x earlier than 5.4.5, and is, therefore, potentially affected by an unspecified overflow vulnerability in the function '_php_stream_scandir' in the file 'main/streams/streams.c'.


Upgrade to PHP version 5.4.5 or later.

See Also

Plugin Details

Severity: Critical

ID: 60086

File Name: php_5_4_5.nasl

Version: 1.8

Type: remote

Family: CGI abuses

Published: 2012/07/20

Updated: 2018/07/24

Dependencies: 48243

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2012/07/19

Vulnerability Publication Date: 2012/07/19

Reference Information

CVE: CVE-2012-2688

BID: 54638