PHP 5.4.x < 5.4.5 _php_stream_scandir Overflow

critical Nessus Plugin ID 60086
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is affected by an overflow vulnerability.

Description

According to its banner, the version of PHP installed on the remote host is 5.4.x earlier than 5.4.5, and is, therefore, potentially affected by an unspecified overflow vulnerability in the function '_php_stream_scandir' in the file 'main/streams/streams.c'.

Solution

Upgrade to PHP version 5.4.5 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.4.5

Plugin Details

Severity: Critical

ID: 60086

File Name: php_5_4_5.nasl

Version: 1.9

Type: remote

Family: CGI abuses

Published: 7/20/2012

Updated: 1/19/2021

Dependencies: php_version.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 7/19/2012

Vulnerability Publication Date: 7/19/2012

Reference Information

CVE: CVE-2012-2688

BID: 54638