VLC Media Player < 2.0.2 RCE

High Nessus Network Monitor Plugin ID 6518

Synopsis

The remote host contains an application that is vulnerable to a buffer overflow vulnerability

Description

The remote host is running VLC 2.x prior to 2.0.2 and is affected by a heap-based buffer overflow vulnerability. An error exists in the function 'Ogg_DecodePacket' in the file 'modules/demux/ogg.c' that does not properly validate input and can allow a heap-based buffer overflow. Opening a specially crafted file can result in the execution of arbitrary code.

Solution

Upgrade to VLC Media Player version 2.0.2 or later.

See Also

http://www.videolan.org/vlc/releases/2.0.2.html

http://www.openwall.com/lists/oss-security/2012/07/06/2

http://www.nessus.org/u?7fd6c9da

http://www.securitytracker.com/id?1027224

Plugin Details

Severity: High

ID: 6518

File Name: 6518.prm

Family: Web Clients

Published: 2012/07/23

Modified: 2016/11/18

Dependencies: 9797

Nessus ID: 60049

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Patch Publication Date: 2012/05/02

Vulnerability Publication Date: 2012/04/30

Reference Information

CVE: CVE-2012-3377

BID: 54345

OSVDB: 83615