VLC Media Player < 2.0.2 RCE

High Nessus Network Monitor Plugin ID 6518


The remote host contains an application that is vulnerable to a buffer overflow vulnerability


The remote host is running VLC 2.x prior to 2.0.2 and is affected by a heap-based buffer overflow vulnerability. An error exists in the function 'Ogg_DecodePacket' in the file 'modules/demux/ogg.c' that does not properly validate input and can allow a heap-based buffer overflow. Opening a specially crafted file can result in the execution of arbitrary code.


Upgrade to VLC Media Player version 2.0.2 or later.

See Also





Plugin Details

Severity: High

ID: 6518

Family: Web Clients

Published: 2012/07/23

Updated: 2019/03/06

Dependencies: 9797

Nessus ID: 60049

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Patch Publication Date: 2012/05/02

Vulnerability Publication Date: 2012/04/30

Reference Information

CVE: CVE-2012-3377

BID: 54345