PHP 5.4.x < 5.4.3 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 6495

Synopsis

The remote web server uses a version of PHP that is affected by a code execution vulnerability.

Description

Versions of PHP 5.4.x prior to 5.4.3 are affected by the following vulnerabilities :

- The fix for CVE-2012-1823 does not completely correct the CGI query parameter vulnerability. Disclosure of PHP source code and code execution via query paramenters are still possible. Note that his vulnerability is exploitable only when PHP is used by CGI-based configurations. Apache with 'mod-php' is not an exploitable configuration. (CVE-2012-2311, CVE-2012-2335, CVE-2012-2336)
- An unspecified buffer overflow exists related to the function 'apache_request_headers'. (CVE-2012-2329)
- An arbitrary code execution vulnerability which affects the function 'com_event_sink()' when processing a specially crafted COM object.

Solution

Upgrade to PHP version 5.4.3 or later.

See Also

http://eindbazen.net/2012/05/php-cgi-advisory-cve-2012-1823

https://bugs.php.net/bug.php?id=61910

http://www.php.net/archive/2012.php#id2012-05-08-1

http://www.php.net/ChangeLog-5.php#5.4.3

Plugin Details

Severity: High

ID: 6495

Family: Web Servers

Published: 2012/06/05

Modified: 2016/11/23

Dependencies: 8682

Nessus ID: 59057, 59088

Risk Information

Risk Factor: High

CVSSv2

Base Score: 8.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 6.9

Temporal Score: 6.4

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2012/05/08

Vulnerability Publication Date: 2012/05/06

Exploitable With

Metasploit (PHP apache_request_headers Function Buffer Overflow)

Reference Information

CVE: CVE-2012-2311, CVE-2012-2329, CVE-2012-2335, CVE-2012-2336

BID: 53388, 53455, 53642