PHP 5.4.x < 5.4.3 Multiple Vulnerabilities

High Nessus Plugin ID 59057

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP installed on the remote host is 5.4.x earlier than 5.4.3. It is, therefore, potentially affected the following vulnerabilities :

- The fix for CVE-2012-1823 does not completely correct the CGI query parameter vulnerability. Disclosure of PHP source code and code execution are still possible.
Note that this vulnerability is exploitable only when PHP is used in CGI-based configurations. Apache with 'mod_php' is not an exploitable configuration.
(CVE-2012-2311, CVE-2012-2335, CVE-2012-2336)

- An unspecified buffer overflow exists related to the function 'apache_request_headers'. (CVE-2012-2329)

Solution

Upgrade to PHP version 5.4.3 or later.

See Also

http://eindbazen.net/2012/05/php-cgi-advisory-cve-2012-1823/

https://bugs.php.net/bug.php?id=61910

http://www.php.net/archive/2012.php#id2012-05-08-1

http://www.php.net/ChangeLog-5.php#5.4.3

Plugin Details

Severity: High

ID: 59057

File Name: php_5_4_3.nasl

Version: 1.14

Type: remote

Family: CGI abuses

Published: 2012/05/09

Updated: 2018/07/24

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 8.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2012/05/08

Vulnerability Publication Date: 2012/05/06

Exploitable With

Core Impact

Metasploit (PHP apache_request_headers Function Buffer Overflow)

Reference Information

CVE: CVE-2012-2311, CVE-2012-2329, CVE-2012-2335, CVE-2012-2336

BID: 53388, 53455

CERT: 520827