Samba 3.x < 3.6.4 / 3.5.14 / 3.4.16 RPC Multiple Buffer Overflows

Critical Nessus Network Monitor Plugin ID 6443

Synopsis

The remote Samba server is affected multiple buffer overflow vulnerabilities.

Description

According to its banner, the version of Samba 3.x running on the remote host is earlier than 3.6.4 / 3.5.14 / 3.4.16. It is, therefore, affected by multiple heap-based buffer overflow vulnerabilities.

An error in the DCE/RPC IDL (PIDL) compiler causes the RPC handling code it generates to contain multiple heap-based buffer overflow vulnerabilities. This generated code can allow a remote, unauthenticated attacker to use malicious RPC calls to crash the application and possibly execute arbitrary code as the root user.

Solution

Either install the appropriate patch referenced in the project's advisory or upgrade to 3.4.16, 3.5.14, 3.6.4, or later.

See Also

https://www.samba.org/samba/security/CVE-2012-1182

http://www.samba.org/samba/history/samba-3.6.4.html

http://www.samba.org/samba/history/samba-3.5.14.html

http://www.samba.org/samba/history/samba-3.4.16.html

Plugin Details

Severity: Critical

ID: 6443

File Name: 6443.prm

Family: Samba

Published: 2012/04/12

Modified: 2016/11/23

Dependencies: 8740

Nessus ID: 58662

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2012/04/10

Vulnerability Publication Date: 2012/04/10

Exploitable With

CANVAS (CANVAS)

Metasploit (Samba SetInformationPolicy AuditEventsInfo Heap Overflow)

Reference Information

CVE: CVE-2012-1182

BID: 52973