Samba 3.x < 3.6.4 / 3.5.14 / 3.4.16 RPC Multiple Buffer Overflows

Critical Nessus Plugin ID 58662


The remote Samba server is affected by multiple buffer overflow vulnerabilities.


According to its banner, the version of Samba 3.x running on the remote host is earlier than 3.6.4 / 3.5.14 / 3.4.16. It is, therefore, affected by multiple heap-based buffer overflow vulnerabilities.

An error in the DCE/RPC IDL (PIDL) compiler causes the RPC handling code it generates to contain multiple heap-based buffer overflow vulnerabilities. This generated code can allow a remote, unauthenticated attacker to use malicious RPC calls to crash the application and possibly execute arbitrary code as the root user.

Note that Nessus has not actually tried to exploit this issue or otherwise determine if one of the associated patches has been applied.


Either install the appropriate patch referenced in the project's advisory or upgrade to 3.6.4 / 3.5.14 / 3.4.16 or later.

See Also

Plugin Details

Severity: Critical

ID: 58662

File Name: samba_rpc_multiple_buffer_overflows.nasl

Version: $Revision: 1.12 $

Type: remote

Family: Misc.

Published: 2012/04/11

Modified: 2016/12/14

Dependencies: 10785

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/04/10

Vulnerability Publication Date: 2012/04/10

Exploitable With


Core Impact

Metasploit (Samba SetInformationPolicy AuditEventsInfo Heap Overflow)

Reference Information

CVE: CVE-2012-1182

BID: 52973

OSVDB: 81303

ZDI: ZDI-12-061, ZDI-12-062, ZDI-12-063, ZDI-12-064, ZDI-12-068, ZDI-12-069, ZDI-12-070, ZDI-12-071, ZDI-12-072