Google Chrome < 17.0.963.83 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 6356

Synopsis

The remote host contains a web browser that is affected by multiple vulnerabilities.

Description

Versions of Google Chrome earlier than 17.0.963.83 are potentially affected by the following vulnerabilities :

- An unspecified integer issue exists in libpng. (CVE-2011-3045)

- Use-after-free errors exist related to 'first-letter' handling, CSS cross-fade handling and block splitting. (CVE-2011-3050, CVE_2011-3051, CVE-2011-3053)

- A memory corruption error exists related to WebGL canvas handling. (CVE-2011-3052)

- An error exists related to webui privilege isolation. (CVE-2011-3054)

- Installation of unpacked extensions does not use the application's native user interface for prompts. (CVE-2011-3055)

- A cross-origin violation is possible with 'magic iframe'. (CVE-2011-3056)

- The v8 JavaScript engine can allow invalid reads to take place. (CVE-2011-3057)

Solution

Upgrade to Google Chrome 17.0.963.83 or later.

See Also

http://googlechromereleases.blogspot.in/2012/03/stable-channel-update_21.html

Plugin Details

Severity: High

ID: 6356

Family: Web Clients

Published: 2012/03/21

Modified: 2016/12/06

Dependencies: 1735, 8314

Nessus ID: 58434

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Patch Publication Date: 2012/03/21

Vulnerability Publication Date: 2012/03/21

Reference Information

CVE: CVE-2011-3045, CVE-2011-3050, CVE-2011-3051, CVE-2011-3052, CVE-2011-3053, CVE-2011-3054, CVE-2011-3055, CVE-2011-3056

BID: 52674