CVE-2011-3045

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Integer signedness error in the png_inflate function in pngrutil.c in libpng before 1.4.10beta01, as used in Google Chrome before 17.0.963.83 and other products, allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PNG file, a different vulnerability than CVE-2011-3026.

References

http://code.google.com/p/chromium/issues/detail?id=116162

http://googlechromereleases.blogspot.com/2012/03/stable-channel-update_21.html

http://libpng.git.sourceforge.net/git/gitweb.cgi?p=libpng/libpng;a=commit;h=a8c319a2b281af68f7ca0e2f9a28ca57b44ceb2b

http://lists.fedoraproject.org/pipermail/package-announce/2012-March/075424.html

http://lists.fedoraproject.org/pipermail/package-announce/2012-March/075619.html

http://lists.fedoraproject.org/pipermail/package-announce/2012-March/075981.html

http://lists.fedoraproject.org/pipermail/package-announce/2012-March/075987.html

http://lists.fedoraproject.org/pipermail/package-announce/2012-March/076461.html

http://lists.fedoraproject.org/pipermail/package-announce/2012-March/076731.html

http://lists.opensuse.org/opensuse-security-announce/2012-04/msg00000.html

http://lists.opensuse.org/opensuse-updates/2012-03/msg00051.html

http://rhn.redhat.com/errata/RHSA-2012-0407.html

http://rhn.redhat.com/errata/RHSA-2012-0488.html

http://secunia.com/advisories/48320

http://secunia.com/advisories/48485

http://secunia.com/advisories/48512

http://secunia.com/advisories/48554

http://secunia.com/advisories/49660

http://security.gentoo.org/glsa/glsa-201206-15.xml

http://src.chromium.org/viewvc/chrome?view=rev&revision=125311

http://www.debian.org/security/2012/dsa-2439

http://www.mandriva.com/security/advisories?name=MDVSA-2012:033

http://www.securitytracker.com/id?1026823

https://bugzilla.redhat.com/show_bug.cgi?id=799000

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A14763

Details

Source: MITRE

Published: 2012-03-22

Updated: 2020-04-14

Type: CWE-190

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

Tenable Plugins

View all (23 total)

IDNameProductFamilySeverity
79286RHEL 5 : rhev-hypervisor5 (RHSA-2012:0488)NessusRed Hat Local Security Checks
medium
74587openSUSE Security Update : chromium / v8 (openSUSE-SU-2012:0466-1)NessusSuSE Local Security Checks
medium
74583openSUSE Security Update : libpng12 / libpng14 (openSUSE-SU-2012:0432-1)NessusSuSE Local Security Checks
medium
69663Amazon Linux AMI : libpng (ALAS-2012-56)NessusAmazon Linux Local Security Checks
medium
68499Oracle Linux 5 / 6 : libpng (ELSA-2012-0407)NessusOracle Linux Local Security Checks
medium
61286Scientific Linux Security Update : libpng on SL5.x, SL6.x i386/x86_64 (20120320)NessusScientific Linux Local Security Checks
medium
60112Slackware 10.0 / 10.1 / 10.2 / 11.0 / 12.0 / 12.1 / 12.2 / 13.0 / 13.1 / 13.37 / 8.1 / 9.0 / 9.1 / current : libpng (SSA:2012-206-01)NessusSlackware Local Security Checks
medium
59668GLSA-201206-15 : libpng: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
58544Fedora 15 : libpng-1.2.48-1.fc15 (2012-3705)NessusFedora Local Security Checks
medium
58465Fedora 16 : libpng-1.2.48-1.fc16 (2012-3739)NessusFedora Local Security Checks
medium
58443Ubuntu 8.04 LTS / 10.04 LTS / 10.10 / 11.04 / 11.10 : libpng vulnerability (USN-1402-1)NessusUbuntu Local Security Checks
medium
58438FreeBSD : chromium -- multiple vulnerabilities (330106da-7406-11e1-a1d7-00262d5ed8ee)NessusFreeBSD Local Security Checks
high
58437Debian DSA-2439-1 : libpng - buffer overflowNessusDebian Local Security Checks
medium
58434Google Chrome < 17.0.963.83 Multiple VulnerabilitiesNessusWindows
high
58424Mandriva Linux Security Advisory : libpng (MDVSA-2012:033)NessusMandriva Local Security Checks
medium
800954Google Chrome < 17.0.963.83 Multiple VulnerabilitiesLog Correlation EngineWeb Clients
high
6356Google Chrome < 17.0.963.83 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
high
58407RHEL 5 / 6 : libpng (RHSA-2012:0407)NessusRed Hat Local Security Checks
medium
58404CentOS 5 / 6 : libpng (CESA-2012:0407)NessusCentOS Local Security Checks
medium
58375Fedora 17 : libpng-1.5.9-1.fc17 (2012-3605)NessusFedora Local Security Checks
medium
58374Fedora 16 : libpng10-1.0.58-1.fc16 (2012-3545)NessusFedora Local Security Checks
medium
58373Fedora 15 : libpng10-1.0.58-1.fc15 (2012-3536)NessusFedora Local Security Checks
medium
58336Fedora 17 : libpng10-1.0.58-1.fc17 (2012-3507)NessusFedora Local Security Checks
medium