Samba 3.6.x < 3.6.3 Denial of Service

Medium Nessus Network Monitor Plugin ID 6299

Synopsis

The remote Samba server is affected by a denial of service vulnerability.

Description

According to its banner, the version of Samba 3.6.x running on the remote host is earlier than 3.6.3. Errors exist in the files 'source3/lib/substitute.c' and 'source3/smbd/server.c' that leak small amounts of memory when processing every connection attempt.

An attacker can continually make connections to the server and cause a denial of service attack against the affected smbd service.

Solution

Either apply one of the patches referenced in the project's advisory or upgrade to 3.6.3 or later.

See Also

http://www.samba.org/samba/security/CVE-2012-0817

http://www.samba.org/samba/history/samba-3.6.3.html

Plugin Details

Severity: Medium

ID: 6299

File Name: 6299.prm

Family: Samba

Published: 2012/02/01

Modified: 2016/01/21

Dependencies: 8740

Nessus ID: 57752

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2012/01/29

Vulnerability Publication Date: 2012/01/29

Reference Information

CVE: CVE-2012-0817

BID: 51713