Samba 3.6.x < 3.6.3 Denial of Service

Medium Nessus Plugin ID 57752

Synopsis

The remote Samba server is affected by a denial of service vulnerability.

Description

According to its banner, the version of Samba 3.6.x running on the remote host is earlier than 3.6.3. Errors exist in the files 'source3/lib/substitute.c' and 'sources3/smbd/server.c' that leak small amounts of memory when processing every connection attempt.

An attacker can continually make connections to the server and cause a denial of service attack against the affected smbd service.

Note that Nessus has not actually tried to exploit this issue or otherwise determine if the patch has been applied.

Solution

Either install the patch referenced in the project's advisory or upgrade to 3.6.3 or later.

See Also

https://www.samba.org/samba/security/CVE-2012-0817

https://www.samba.org/samba/history/samba-3.6.3.html

http://www.nessus.org/u?5ed8bb9b

Plugin Details

Severity: Medium

ID: 57752

File Name: samba_3_6_3.nasl

Version: 1.8

Type: remote

Family: Misc.

Published: 2012/01/31

Updated: 2018/11/15

Dependencies: 10785

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/01/29

Vulnerability Publication Date: 2012/01/29

Reference Information

CVE: CVE-2012-0817

BID: 51713