Flash Player < 10.3.183.11 / 220.127.116.11 Multiple Vulnerabilities (APSB11-28)
High Nessus Network Monitor Plugin ID 6097
SynopsisThe remote host contains a browser plugin that is vulnerable to multiple attack vectors.
DescriptionVersions of Flash Player earlier than 10.3.183.11 / 18.104.22.168 are potentially affected by multiple vulnerabilities :
- Several unspecified memory corruption errors exist that could lead to code execution. (CVE-2011-2445, CVE-2011-2451, CVE-2011-2452, CVE-2011-2453, CVE-2011-2454, CVE-2011-2455, CVE-2011-2459, CVE-2011-2460)
- An unspecified heap corruption error exists that could lead to code execution. (CVE-2011-2450)
- An unspecified buffer overflow error exists that could lead to code execution. (CVE-2011-2456)
- An unspecified stack overflow error exists that could lead to code execution. (CVE-2011-2457)
- An unspecified error related to Internet Explorer can allow cross-domain policy violations. (CVE-2011-2458)
SolutionUpgrade to Flash Player 10.3.183.11, 22.214.171.124 or later.