Flash Player < 10.3.183.11 / 11.1.102.55 Multiple Vulnerabilities (APSB11-28)

High Nessus Network Monitor Plugin ID 6097

Synopsis

The remote host contains a browser plugin that is vulnerable to multiple attack vectors.

Description

Versions of Flash Player earlier than 10.3.183.11 / 11.1.102.55 are potentially affected by multiple vulnerabilities :

- Several unspecified memory corruption errors exist that could lead to code execution. (CVE-2011-2445, CVE-2011-2451, CVE-2011-2452, CVE-2011-2453, CVE-2011-2454, CVE-2011-2455, CVE-2011-2459, CVE-2011-2460)
- An unspecified heap corruption error exists that could lead to code execution. (CVE-2011-2450)
- An unspecified buffer overflow error exists that could lead to code execution. (CVE-2011-2456)
- An unspecified stack overflow error exists that could lead to code execution. (CVE-2011-2457)
- An unspecified error related to Internet Explorer can allow cross-domain policy violations. (CVE-2011-2458)

Solution

Upgrade to Flash Player 10.3.183.11, 11.1.102.55 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb11-28.html

Plugin Details

Severity: High

ID: 6097

Family: Web Clients

Published: 2011/11/18

Modified: 2016/01/19

Dependencies: 5783

Nessus ID: 56874, 56875

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2011/11/10

Vulnerability Publication Date: 2011/11/10

Reference Information

CVE: CVE-2011-2445, CVE-2011-2450, CVE-2011-2451, CVE-2011-2452, CVE-2011-2453, CVE-2011-2454, CVE-2011-2455, CVE-2011-2456, CVE-2011-2457, CVE-2011-2458, CVE-2011-2459, CVE-2011-2460

BID: 50618, 50619, 50620, 50621, 50622, 50623, 50624, 50625, 50626, 50627, 50628, 50629