Flash Player <= 10.3.183.10 / 18.104.22.168 Multiple Vulnerabilities (APSB11-28)
High Nessus Plugin ID 56874
SynopsisThe remote Windows host has a browser plugin that is affected by multiple vulnerabilities.
DescriptionAccording to its version, the instance of Flash Player installed on the remote Windows host is 10.x equal to or earlier than 10.3.183.10 or 11.x equal to or earlier than 22.214.171.124. It is, therefore, reportedly affected by several critical vulnerabilities :
- Several unspecified memory corruption errors exist that could lead to code execution. (CVE-2011-2445, CVE-2011-2451, CVE-2011-2452, CVE-2011-2453, CVE-2011-2454, CVE-2011-2455, CVE-2011-2459, CVE-2011-2460)
- An unspecified heap corruption error exists that could lead to code execution. (CVE-2011-2450)
- An unspecified buffer overflow error exists that could lead to code execution. (CVE-2011-2456)
- An unspecified stack overflow error exists that could lead to code execution. (CVE-2011-2457)
- An unspecified error related to Internet Explorer can allow cross-domain policy violations. (CVE-2011-2458)
SolutionUpgrade to Adobe Flash version 10.3.183.11 / 126.96.36.199 or later.