Apache 2.2 < 2.2.21 mod_proxy_ajp DoS

low Nessus Network Monitor Plugin ID 6062
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is vulnerable to a denial of service attack.

Description

Versions of Apache 2.2 earlier than 2.2.21 are potentially affected by a denial of service vulnerability. An error exists in the mod_proxy_ajp module that can allow specially crafted HTTP requests to cause a backend server to temporarily enter an error state. This vulnerability only occurs when mod_proxy_ajp is used along with mod_proxy_balancer.

Solution

Upgrade to Apache version 2.2.21 or later.

See Also

http://httpd.apache.org/security/vulnerabilities_22.html

https://archive.apache.org/dist/httpd/CHANGES_2.2.21

Plugin Details

Severity: Low

ID: 6062

Family: Web Servers

Published: 11/3/2011

Updated: 3/6/2019

Dependencies: 3057

Nessus ID: 56216

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: Low

Base Score: 3.7

Temporal Score: 3.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:2.0:*:*:*:*:*:*:*

Patch Publication Date: 9/14/2011

Vulnerability Publication Date: 9/14/2011

Reference Information

CVE: CVE-2011-3348

BID: 49616