Apache 2.2.x < 2.2.21 mod_proxy_ajp DoS

medium Nessus Plugin ID 56216
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server is affected by a denial of service vulnerability.


According to its banner, the version of Apache 2.2.x running on the remote host is prior to 2.2.21. It is, therefore, potentially affected by a denial of service vulnerability. An error exists in the 'mod_proxy_ajp' module that can allow specially crafted HTTP requests to cause a backend server to temporarily enter an error state. This vulnerability only occurs when 'mod_proxy_ajp' is used along with 'mod_proxy_balancer'.

Note that Nessus did not actually test for the flaws but instead has relied on the version in the server's banner.


Upgrade to Apache version 2.2.21 or later.

See Also



Plugin Details

Severity: Medium

ID: 56216

File Name: apache_2_2_21.nasl

Version: 1.16

Type: remote

Family: Web Servers

Published: 9/16/2011

Updated: 6/29/2018

Dependencies: apache_http_version.nasl

Risk Information


Risk Factor: Low

Score: 2.2


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Ease: No known exploits are available

Patch Publication Date: 9/14/2011

Vulnerability Publication Date: 9/14/2011

Reference Information

CVE: CVE-2011-3348

BID: 49616