Flash Player < 10.3.183.10 Multiple Vulnerabilities (APSB11-26)

High Nessus Network Monitor Plugin ID 6025

Synopsis

The remote host contains a browser plugin that is vulnerable to multiple attack vectors.

Description

Versions of Flash Player earlier than 10.3.183.10 are potentially affected by multiple vulnerabilities :
- Multiple AVM stack overflow vulnerabilities could lead to code execution. (CVE-2011-2426, CVE-2011-2427)
- A logic error issue could lead to code execution or a browser crash. (CVE-2011-2428)
- A Flash Player security control bypass vulnerability could lead to information disclosure. (CVE-2011-2429)
- A streaming media logic error vulnerability could lead to code execution. (CVE-2011-2430)
- A universal cross-site scripting vulnerability could be abused to take actions on a user's behalf on any website if the user is tricked into visiting a malicious website. Note that this issue is reportedly being actively exploited in targeted attacks. (CVE-2011-2444)

Solution

Upgrade to Flash Player 10.3.183.10 or later.

See Also

https://github.com/zrong/blog/tree/master/flashplayer_crash_on_netstream_play/project

http://www.adobe.com/support/security/bulletins/apsb11-26.html

Plugin Details

Severity: High

ID: 6025

Family: Web Clients

Published: 2011/09/22

Updated: 2019/03/06

Dependencies: 5783

Nessus ID: 56258, 56259

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2011/09/21

Vulnerability Publication Date: 2011/09/21

Reference Information

CVE: CVE-2011-2426, CVE-2011-2427, CVE-2011-2428, CVE-2011-2429, CVE-2011-2430, CVE-2011-2444

BID: 49710, 49714, 49715, 49716, 49717, 49718