OpenSSL 1.x < 1.0.0e Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 6022
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

Versions of OpenSSL 1.0.0 earlier than and 1.0.0e are potentially affected by the following vulnerabilities :

- An error exists in the internal certificate verification process that can allow improper acceptance of a certificate revolcation list (CRL) if the lists's 'nextUpdate' field contains a date in teh past. Note that this internal CRL checking is not enabled by defaut. (CVE-2011-3207)

- An error exists in the code for the ephemeral (EC)DH ciphersuites that can allow a remote attacker to crash the process. (CVE-2011-3210)

Solution

Upgrade to OpenSSL 1.0.0e or later.

See Also

http://www.openssl.org/news/changelog.html

http://openssl.org/news/secadv_20110906.txt

https://bugzilla.redhat.com/show_bug.cgi?id=736079

https://bugzilla.redhat.com/show_bug.cgi?id=736087

Plugin Details

Severity: Medium

ID: 6022

Family: Web Servers

Published: 9/6/2011

Updated: 3/6/2019

Dependencies: 5563

Nessus ID: 56162

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:*

Patch Publication Date: 9/6/2011

Vulnerability Publication Date: 9/6/2011

Reference Information

CVE: CVE-2011-3207, CVE-2011-3210

BID: 49469, 49471