OpenSSL 1.x < 1.0.0e Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 6022


The remote web server is affected by multiple vulnerabilities.


Versions of OpenSSL 1.0.0 earlier than and 1.0.0e are potentially affected by the following vulnerabilities :

- An error exists in the internal certificate verification process that can allow improper acceptance of a certificate revolcation list (CRL) if the lists's 'nextUpdate' field contains a date in teh past. Note that this internal CRL checking is not enabled by defaut. (CVE-2011-3207)

- An error exists in the code for the ephemeral (EC)DH ciphersuites that can allow a remote attacker to crash the process. (CVE-2011-3210)


Upgrade to OpenSSL 1.0.0e or later.

See Also

Plugin Details

Severity: Medium

ID: 6022

Family: Web Servers

Published: 9/6/2011

Updated: 3/6/2019

Nessus ID: 56162

Risk Information


Risk Factor: Medium

Score: 5.2


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N


Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Patch Publication Date: 9/6/2011

Vulnerability Publication Date: 9/6/2011

Reference Information

CVE: CVE-2011-3207, CVE-2011-3210

BID: 49469, 49471